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Common Troubleshooting for EBis 3 
 

Below is a list of common issues that can occur with EBis 3.  Please read through this several page document to 
see if your question is answered. 

 

Where is the latest EBis User’s Manual? 
 

www.datcomedia.com/pdf/ebis3/manual/ebis3_manual.zip 
 
 

I have a new computer – where can I find the latest client 
installer? 
 

www.partsexpress247.com/EBis3_Upgrades/client/ebis3_client.zip 
 
If there are any problems when the installer starts, make sure you are using an ADMIN windows account. 

 
After Upgrading – EBis says the version is not correct, or you 
receive many errors in EBis 
 

Go to the computer having the problem, and go to the c:\Program Files\EBis 3 Client folder.  Delete the 
"EBis3.exe" file.  Then double-click on the AppLauncher.exe file.  This will copy the newest files over from the 
server.  If you get an error, check your network connection, ensuring that the client computer is connecting to the 
server correctly to find the newest version of EBis, and make sure the newest version does indeed exist in the 
location on the server. 
 
The diagram on the next page explains the setup. 
 
If you are uncertain about if the AppLauncher.exe file is pointing to the correct place, from the client machine, 

you can delete the c:\Program Files\EBis 3 Client\AppLauncher.xml file.  Then, double-click on 
AppLauncher.exe – this will ask you to specify the location of the EBis server files (usually the Server\EBis 3 
mapped drive, such as Z). 
 
Normally the problems if users aren’t being updated with the newest version are: 
 

1) Make sure you are logged into each client computer as the Windows administrator for that computer. 
 

2) The shortcut they are starting EBis with is going directly to the EBis3.exe file.  It should go to the: 
c:\Program Files\EBis 3 Client\AppLauncher.exe file.  Make sure all users are using a 
shortcut that points to the AppLauncher.exe file. 

 
3) AppLauncher.exe is pointing to the incorrect or inaccesible location (the mapped drive may not be 

accessible, etc.).  You can check the location by clicking on the c:\Program Files\EBis 3 

Client\AppLauncher.xml file.  If this is incorrect, close and delete this file, and re-run the 
AppLauncher.exe file to specify a new location. 
 
Also, make sure that the path specified (such as Z:\) is accessible via “My Computer” or “Windows 
Explorer”. 

 
4) If EBis 3 is being run from the server computer, make sure the server machine is also accessing the EBis 

via the “AppLauncher.exe” method.  You can either map the \\Server\EBis 3 folder, or select 

c:\Program Files\EBis 3 in the AppLauncher setup. 
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5) Make sure that the newest files are really in the \\Server\EBis 3  folder.  If users are running the 
application from this folder, the files will be locked because they are in use and are not accessible. 

 
6) Make sure EBis 3 runs (for testing purposes only) from c:\Program Files\EBis 3 on the server 

computer.  Sometimes the user has an invalid database connection string, which means whenever there is 
an update the invalid connection information is being sent to all client machines.   

 

 
 



3 of 6 

Connection Issues with SQL 2005/2008, 
Configuring SQL 2005/2008 
 

www.datcomedia.com/pdf/support/sql2008.pdf 

 
Windows 7 / Vista Client Connection Issues 
 

If you experience: 
• Crashes with the 64-bit version 
• Connection problems 
• Problems receiving the latest files from the server after an upgrade 

 
1. Turn off User Access Control (Start Menu > Control Panel > Action Center > “Change User Account Control 

Settings” and turn it off) 
2. Start EBis using the “Run as Administrator”.  To do this, right-click on the icon that you start EBis from, 

select “Properties”, then go to “Compatibility” and select “Run this program as an administrator”. 

 
After Upgrading – Database Was Not Updated 
 

If the database was not upgraded, it means the UpgradeDB3 was not run.  Please do the following: 
  

1) Make sure all users are not in EBis 3. 
2) Go to the server computer 
3) Go to the c:\Program Files\EBis 3 folder 
4) Double-click on the “UpgradeDB3.exe” file. 
5) Type in the server information and password and press “Connect”. 
6) Press the “Upgrade Database Structure” button, and it will perform the necessary upgrades to your 

database. 
7) Once this has been completed, restart EBis on the client computers. 
 
If problems persist, make sure the latest EBis 3 client has been installed on the computer having difficulty, and 
make sure you have the latest version of EBis. 

 
 

Migrating the EBis database to a new server 
 

Download and read the PDF file in the zip file: 
www.datcomedia.com/download/ebis_migrate.zip 
 

Installing SQL Server 2005 Workgroup, Standard, Enterprise 
 

See: http://www.datcomedia.com/pdf/ebis3/install_sql2005.pdf 
These instructions should work with SQL 2008, although the screens may be somewhat different. 
 

No names appear in the drop-down when starting EBis 
 

1. Make sure the correct server information is entered in View > Database Connection Preferences. 
2. Make sure ALL software firewalls (Norton, Windows, McAfee, etc.) on ALL computers are turned OFF. 
3. See:  

a. www.datcomedia.com/pdf/support/sql2008.pdf 
b. www.datcomedia.com/pdf/ebis3/connectivity.pdf 
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A user cannot check in items to a Purchase Order 
 

To check in parts, the user must have the following access: 
 

Repair Orders: create parts, edit parts, delete parts 
Work Orders: create parts, edit parts, delete parts 
Master Parts: edit 
Purchase Orders: edit 

 
To check in service items, the user must have the following access: 

 
Repair Orders: general create, general edit 
Work Orders: general create, general edit 
Master Parts: edit 
Purchase Orders: edit 

 
Also, make sure the P/O status is “Ordered”. 
 
Manually Backing up EBis Database 

 
From the server computer, start EBis 3 and go to the Admin Menu > Data Admin Functions and select “Backup 
Database” and press “Execute”. 
 
 

Automatically Backing up EBis Database 

 
To backup EBis (v3415 and later), you can do the following from the server machine. 
 
For Windows 7 (or Vista) users:  

1. Go to the Scheduled Tasks option from your Start Menu. 
2. Action menu > “Create a New Task”. 
3. For the name: “EBis Backup”. 
4. Check “Run whether user is logged in or not”. 
5. Check “Run with highest privileges”. 
6. In the Triggers tab, press “New” and specify the desired interval. 
7. In the Actions tab, press “New”.  
8. The action should be “Start a program”. 
9. Press the “Browse” button and select the c:\Program Files\EBis 3\EBis3.exe file. 
10. In the “Add arguments (optional)” field, type in: \backup 
11. Press OK to close the New Action screen. 
12. Press OK to save the task. 

 
13. Go to the c:\Program Files\EBis 3 folder. 
14. Right-click within the folder and select New > Text Document. 
15. Rename the new text file to “backup_path.txt”. 
16. Open up the file and specify where you want the backups to be saved to. 

a. Example: 
Specify C:\EBisBackups to save the files to a folder called “EBisBackups” 

17. Save the text file by going to File > Save.  Then close the screen. 
18. The backup is now setup.  Logs are kept in the location where the backups are copied to. 

Please make sure to constantly check that the backup was made. 
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Clearing the EBis 3 SQL Transaction Log 
 
From EBis 3, go to Admin Menu > Data Admin functions > “Clear Transaction Log” and press “Execute”. 
 

Restoring the EBis 3 Database from a SQL Backup 
 

- From the server computer or another computer that has the SQL Query Analyzer or SQL Server Management 
Studio program on it. 

- Go to Start Menu > Run > and type isqlw and press enter 
- Enter your server and user information and press OK. 

- Copy and paste the below information to the “Query” window. 

 

restore database EBis3 from disk = 'c:\EBisBackups\EBisBackupHere.bak' 

 

- Once entered, go to Query menu and select “Execute”.  If the information was entered successfully, your 
information will be restored. 

- Please note that the EBis3 catalog must be bound to SQL Server before this can be run. 
 

The Pricing “Mark-up” Formula for Cost+ Explained 
 
If you have a cost of $10,000, and a mark-up (using the correct way), you would get $1428.57.  If you then take 
30% back off the part, you would get $10,000, which is the number you started at. 

  

However, if you don't use the markup, and have a cost of $10,000 and use the non-markup calculation to get 
$13,000.00, if you take 30% off, you would get $9,100.00, which is far less than the number you started from. 

  

You can turn this feature in EBis by going to View > Preferences > Parts tab > More Options tab... and check "Do 
not use the markup formula".  However, I would advise against this, as you will be LOSING money by not using this 
formula.  You can also read more about this formula by doing a search on Google. 
 

Adding Time Overrides… What access is needed? 
 
If they are using technician codes (a code to start/stop the timer): 

The user account of the technician code entered must allow time overrides and either: 
 
1) The user account that entered the technician code has admin access 
Or 
2) The technician record (in service tab) must match the username of the inspection code entered 

 
If they are NOT using technician codes (a code to start/stop the timer) : 

The logged in user account must allow time overrides and either: 
 
1)The logged in user account has “change other techs” access 
Or 
2) The technician record (in service tab) must match the username of the user logged into the system 
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What is a “data concurrency” error? 
 
This is an error that occurs when more than one user is accessing the same record (such as a part number) at the 
same time. 

 
Shipping Costs on Purchase Orders – why does it sometimes 
add up to more than the original amount? 
 
For rounding purposes, it may add a small amount to the number to makes sure that all shipping is collected.  Since 
it is split up among all parts on the P/O, without this, you could end up only collecting, for example, $12.30 instead 
of at least the $12.34.  So, in some cases, you will collect slightly more than the amount needed.  This is a fail-safe 
built into the system. 
 
And it will not distribute it evenly. 
 
Example: 
If you have two parts: 
 
Part #100, qty 1, $50.00, ordered for a W/O 
Part #200, qty 1, $10.00, ordered for a W/O 
 
And you have a shipping of $20.00. 
 
For part #100, which was $50.00, and accounts for 83.33% of the invoice (since it’s $50 out of the total $60), it will 
figure out the shipping by calculating $20.00 x (83.33% + 1.00% (to avoid rounding issues where the invoice is not 
accounted for) = $16.87. 
 
For part #200, will be (($10/$60) + .01) * $20.00 = $3.53.  So you end up collecting 16.87 + 3.53 = $20.40 instead 
of $20.00.  The reason we added this extra .01% to it is, without this, people were calling and complaining that they 
were being shortchanged a few cents in various cases. 
 

Other EBis Related Issues 
 

1. Sending a User Removal Code: 
 
In EBis 3, go to Help > About EBis, click on "Current Users", double-click on the name stuck in the 
system, and then press the "Send Msg to DatcoMedia, Requesting Code" button.  Then close the "About 
Screen" and send the message by pressing the "Send Message" button. 
 
To understand why users get stuck in EBis and how to remove them without a code: 
http://www.datcomedia.com/pdf/ebis3/stuck_users.pdf 

 
2. Sending a Work Order to Look At: 

 
From the work order, go to Options > “Email Work Order”.  Then press the “Get Information” button.  A 
message will appear, saying the information is now on your Windows Clipboard.  Then go back to your 
email program, create a new message, put the cursor in the message body, and go to Edit > Paste.  Then 
send the message to the proper user (probably support@datcomedia.com or michael@datcomedia.com). 

 

 


